Welcome! Log In Create A New Profile Recent Messages

Advanced

Log In / Log Out

Posted by Ferdinand 
December 22, 2008 12:26PM
On my home computer I stay permanently logged in to this forum. Whenever I visit I can see which topic sections have new unread messages etc.

But on my office computer I always have to log in first. If I close my browser, or even just go visit a different site, when I return to the BENN forum I find I've been automatically logged out and must log in again before being able to post.

What's up with that?

Is this a cookie issue? How can I fix it so I stay logged in from either computer?
December 22, 2008 01:36PM
Quote
Ferdinand
On my home computer I stay permanently logged in to this forum. Whenever I visit I can see which topic sections have new unread messages etc.

But on my office computer I always have to log in first. If I close my browser, or even just go visit a different site, when I return to the BENN forum I find I've been automatically logged out and must log in again before being able to post.

What's up with that?

Is this a cookie issue? How can I fix it so I stay logged in from either computer?

If your work computer is on a network, the IT people probably logi ti off auto matically when they do backups.
December 22, 2008 04:18PM
Quote
Ferdinand
Is this a cookie issue? How can I fix it so I stay logged in from either computer?
I think this is a cookie issue. The forums are set to issue a cookie that will save your login credentials for 30 days. My guess is that the browser on your work computer is not getting this cookie. Are cookies turned on? Can you try a different browser program to see if it does the same thing?

__________
Dave
'91 325iX
December 23, 2008 09:55AM
Quote
Archeo-peteriX
If your work computer is on a network, the IT people probably log it off automatically when they do backups.
It's only doing this with the BENN forum. Every other forum, when logging in, I can select an option to stay logged in. I can close my browser or visit another site, but when I revisit these other forums I'm still logged in. But not the BENN forum. If I close the browser window, or go to any other site and then come back immediately to the BENN forum, I'm logged out and have to log in again.

The odd thing is that it only does this to me on my work computer, not my home laptop. I'm using Firefox v3.0.5 on each computer.

Using MS-Explorer I have no problem on either computer. The problem only occurs using Firefox on my office computer.
December 23, 2008 10:03AM
Quote
Ferdinand
Using MS-Explorer I have no problem on either computer. The problem only occurs using Firefox on my office computer.
That strengthens my suspicion that this is an issue with cookies on your office computer. Check the settings under Tools > Options > Privacy, and make sure that Firefox is configured to accept cookies, and to keep them until they expire.

__________
Dave
'91 325iX
December 23, 2008 11:24AM
Quote
Dave_G
That strengthens my suspicion that this is an issue with cookies on your office computer. Check the settings under Tools > Options > Privacy, and make sure that Firefox is configured to accept cookies, and to keep them until they expire.
Aha! I think I figured it out.

I compared the Privacy settings for cookies on both computers and the only difference was that the work computer (the one with the problem) is set to accept and keep cookies until the expire. My home computer (which works fine) is set to accept third-party cookies but "ask me every time".

I tried reversing those settings on each, deleting the existing cookies, but I still get the same result each time. My home computer will stay logged in forever unless I click the Log Out option on the BENN forum. My work computer automatically logs me off whenever I leave the BENN forum. What's up with that?

After lots of trial and error, I finally managed to reproduce the problem on both computers.

On my home computer I have the site bookmarked as http://bmwe30network.net/. From there I click the link to the forum, which takes me to http://bmwe30network.net/forums/. Clicking the link to log in takes me to http://bmwe30network.net/forums/login.php. Successfully logged in, I am returned to http://bmwe30network.net/forums/index.php and everything's cool from there. I can go away, close the browser, next time I visit I'm still logged in.

On my office computer I had the site bookmarked directly to the forum at http://www.bmwe30network.net/forums/. Click log in, it takes me to http://bmwe30network.net/forums/login.php. Successfully logged in, I am returned to http://bmwe30network.net/forums/index.php and everything's cool until I go away to another site, or close the browser. Next time I visit http://www.bmwe30network.net/forums/, I'm no longer logged in and have to re-enter my password to get logged in.

Can you see the difference?

It's the "www".

http://bmwe30network.net/forums/
http://www.bmwe30network.net/forums/

They both work, but only the one without the www will remember that you're logged in.
December 23, 2008 11:58AM
Quote
Ferdinand
Quote
Dave_G
That strengthens my suspicion that this is an issue with cookies on your office computer. Check the settings under Tools > Options > Privacy, and make sure that Firefox is configured to accept cookies, and to keep them until they expire.
Aha! I think I figured it out.

I compared the Privacy settings for cookies on both computers and the only difference was that the work computer (the one with the problem) is set to accept and keep cookies until the expire. My home computer (which works fine) is set to accept third-party cookies but "ask me every time".

I tried reversing those settings on each, deleting the existing cookies, but I still get the same result each time. My home computer will stay logged in forever unless I click the Log Out option on the BENN forum. My work computer automatically logs me off whenever I leave the BENN forum. What's up with that?

After lots of trial and error, I finally managed to reproduce the problem on both computers.

On my home computer I have the site bookmarked as http://bmwe30network.net/. From there I click the link to the forum, which takes me to http://bmwe30network.net/forums/. Clicking the link to log in takes me to http://bmwe30network.net/forums/login.php. Successfully logged in, I am returned to http://bmwe30network.net/forums/index.php and everything's cool from there. I can go away, close the browser, next time I visit I'm still logged in.

On my office computer I had the site bookmarked directly to the forum at http://www.bmwe30network.net/forums/. Click log in, it takes me to http://bmwe30network.net/forums/login.php. Successfully logged in, I am returned to http://bmwe30network.net/forums/index.php and everything's cool until I go away to another site, or close the browser. Next time I visit http://www.bmwe30network.net/forums/, I'm no longer logged in and have to re-enter my password to get logged in.

Can you see the difference?

It's the "www".

http://bmwe30network.net/forums/
http://www.bmwe30network.net/forums/

They both work, but only the one without the www will remember that you're logged in.

By crikey, I think you've nailed it! Excellent sleuthing Ferd smileys with beer
December 23, 2008 04:08PM
Quote
Archeo-peteriX
Quote
Ferdinand
It's the "www".

http://bmwe30network.net/forums/
http://www.bmwe30network.net/forums/

They both work, but only the one without the www will remember that you're logged in.

By crikey, I think you've nailed it! Excellent sleuthing Ferd smileys with beer

It's not browser dependent. The same thing happens in MS-Explorer.
December 23, 2008 05:21PM
Quote
Ferdinand
Quote
Archeo-peteriX
Quote
Ferdinand
It's the "www".

http://bmwe30network.net/forums/
http://www.bmwe30network.net/forums/

They both work, but only the one without the www will remember that you're logged in.

By crikey, I think you've nailed it! Excellent sleuthing Ferd smileys with beer

It's not browser dependent. The same thing happens in MS-Explorer.

Different OS or versions?
December 23, 2008 05:52PM
mmmm cookies.


December 23, 2008 06:41PM
Quote
daniel
mmmm cookies.

Yep, that helps smiling smileyo
December 26, 2008 04:07PM
Quote
Archeo-peteriX
Quote
Ferdinand
It's not browser dependent. The same thing happens in MS-Explorer.

Different OS or versions?
No, it has nothing to do with operating systems or browser versions.

When you log-in to this forum it sets a browser cookie as "bmwe30network.net" called "phorum_session_v5". That cookie is set to expire in one month. As long as you don't manually log-off, it will remember you whenever you return to this forum up to one month's time. After that you will need to log-in again.

This works fine if you have bookmarked this forum as [bmwe30network.net], as I have on my home computer.

My problem was that on my office computer I had the forum bookmarked under [www.bmwe30network.net]. The browser jumped to the correct website, no problem. But the "www" page didn't recognize the cookies set without a "www".

http://bmwe30network.net/forums/ This page works fine.
http://www.bmwe30network.net/forums/ This page doesn't recognize or remember the cookies.

They both work, but only the one without the www will remember that you're logged in.
January 03, 2009 12:04PM
Quote
Ferdinand
They both work, but only the one without the www will remember that you're logged in.
That's annoying. I'll see if I can fix that.

__________
Dave
'91 325iX
January 06, 2009 02:50PM
Maybe your work computer is trying to get you to spend less time on forums and more on working?

Cab
1990 325i(s)
2004 325XiT
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 6
Record Number of Users: 3 on September 29, 2015
Record Number of Guests: 116 on November 11, 2017