Welcome! Log In Create A New Profile Recent Messages

Advanced

Buying new sparks? Locking nut for steering wheel?

Posted by Kelly 
Hi Guys,

Hope all is well! My Bro called yesterday to announce his imminent arrival here in CA. Means that we can change the spark plugs.

What brand and type should I buy for a normal street driving Beemie? (1989 325i Convertible)

Also, Bentley said something about a locking nut for the steering wheel that needs replacement after removing the wheel. What is the scoop with this?

Please let me know ASAP if possible. Hopefully I can visit the auto store tomorrow.

B) Kelly
the spark plugs you get need to be the copper filamented ones, not the silver or platinum. i don't know the exact part number, but maybe someone in here will.

as for the locking nut, im not sure i know what you are talking about. there is a big nut (maybe 21mm?) under the roundel in the steering wheel which is used to hold the steering wheel on. i don't remember anything "locking" it in, though.


Bosch W8LCR / W8LPR (+) ; NGK ZGR5A .028"- .032" (0.7 - 0.8 mm)

The steering wheel locking nut has a plastic ring in it, preventing it from getting loose. Honestly, I never bothered to replace that one after removal, as long as you feel the plastic part is still keeping it from getting loose.
Quote
Michiel 318iS
The steering wheel locking nut has a plastic ring in it, preventing it from getting loose. Honestly, I never bothered to replace that one after removal, as long as you feel the plastic part is still keeping it from getting loose.
Me neither. I've had my steering wheel off twice, and used the same nut both times. It's still holding fine (knock on wood).

__________
Dave
'91 325iX
You'd feel it coming loose as it would wobble.
Get the Bosch plugs...they are OEM and they don't cost too much comparatively. As far as the steering wheel nut, if you are really concerned you could put a little loctite on the threads or just order a new one, it probably doesn't matter to much. It is not as if we are talking brakes or anything here. You will know if the steering wheel nut gets loose as the wheel will have play in it if you pull it toward you. For the nut to completely come off and the wheel to come off would be almost impossible for anybody that knows how the wheel is supposed to feel. Just be sure and torque it properly!
Quote
Michiel 318iS
Bosch W8LCR / W8LPR (+) ; NGK ZGR5A .028"- .032" (0.7 - 0.8 mm)

Make sure the plugs have the correct gap. IIRC, when I ordered the W8LCR they had the wrong gap and you need a special tool to adjust it. NGKs can be bought with the right gap out of the box, maybe you can also get the Bosch ones with the right gap.

Spark plug brands are a matter of religion, so I'm not gonna say what's better for fear of starting a Holy War!

If you like, you could also post close-up photos of your old plugs here and we could show you how to "read" them to check the health of your engine.



Edited 1 time(s). Last edit at 03/02/2009 07:59PM by nomis3613.
Hi Kelly,
you got some good information, but additionally take a look at this DIY article to find out everything you need to know about BMW e30 sparkplug replacement smiling smiley



Quote
Kelly
Hi Guys,

Hope all is well! My Bro called yesterday to announce his imminent arrival here in CA. Means that we can change the spark plugs.

What brand and type should I buy for a normal street driving Beemie? (1989 325i Convertible)

Also, Bentley said something about a locking nut for the steering wheel that needs replacement after removing the wheel. What is the scoop with this?

Please let me know ASAP if possible. Hopefully I can visit the auto store tomorrow.

B) Kelly
rkj
Kelly, NGK plugs are what you want and forget about the nut on the wheel, its the nut behind the wheel thats important winking smiley

Don't forget to coat the threads, even grease will do; keeps the carbon from walking up the threads and blowing out the plug wells is a good thing before you start pulling the plugs (have some solvent in case they're tight coming out; DON'T rush it), can air is okay if you don't have a compressor, you'd be surprised what comes outa there!

Radio shack has the car air thumbs up

Replacing spark plugs can go wrong if you're not careful.

Rick
Quote
rkj
Kelly, NGK plugs are what you want and forget about the nut on the wheel, its the nut behind the wheel thats important winking smiley

Don't forget to coat the threads, even grease will do; keeps the carbon from walking up the threads and blowing out the plug wells is a good thing before you start pulling the plugs (have some solvent in case they're tight coming out; DON'T rush it), can air is okay if you don't have a compressor, you'd be surprised what comes outa there!

Radio shack has the car air thumbs up

Replacing spark plugs can go wrong if you're not careful.

Rick

Hi All,

Well I ordered the Bosch spark plugs yesterday, and they arrived today.

The box says Bosch Super Plus 7909 WR8LC+ which is a little different than above W8LCR+. But I assume it is the same part. Please let me know if it is the wrong part. Apparently "50% longer lasting the OE copper plugs. Premium Copper core plus Yttrium." The box is a black and copper color.

Rick - I like the air can and solvent idea. The Bro and I will clean well.

Dumb as it sounds, I don't have any regular grease. I do have di-electric grease. Could I use it? Or would that be a bad idea? OR I can easily buy regular grease or anti-seize compound. Well, let me know...

;-) Kelly
rkj
Use the anti-seize compound, just make sure you mix it before every use. That stuff settles overnight smileys with beer You're using the grease (heavy as possible or the antiseize for two reasons; 1- keeping the carbon from walking up the threads and causing striping and 2 plugs are steel and the head is alloy= dissimilar metals, they tend to get horny and like eachother too much thumbs down
I wouldn't trust any plug gap to be right out of the box. Always check the gap on every plug before installing it. You never know what klutz at the parts place may have dropped the box, or if the shipper Ace Ventura'd the box on its way to them. We just had someone do an engine swap in another forum and the new engine wouldn't start. After a couple days of troubleshooting he found out it was because the plugs were so far out of spec. It only takes a second to be sure, and just so you know, the "special tool" is only about a buck and a half at a auto parts place.

ps. Make sure to get the one with the wire loops to check the gap as the one with the graduated edge will give incorrect readings if you don't have it perfectly straight (perpendicular to the electrode).
Quote
Andy 90 325i
I wouldn't trust any plug gap to be right out of the box. Always check the gap on every plug before installing it.
+1

I always check the gaps. It's a habit I developed years ago when spark plugs never came "pre-gapped." Even though they're supposed gapped correctly now, I still frequently find plugs that I need to tweak a little.

__________
Dave
'91 325iX
Hi All,

So, the Bro arrived Fri evening with a Craftsman MicroTorque wrench. Apparently he had* to visit 3 tool shops on the drive to my place.
( * = easily replaced with "chose" in this case.)

Sat morning Beemie went "under the wrench" to remove and reinstall the Instrument Cluster. The main goal was determining if the batteries could be remotely located; the minor goals were to replace light bulbs as a preventative measure and buff out some etched white spots on the clear front plastic cover. We followed the E30 Dash Removal instructions to remove the steering wheel. And I have to say that 58FtLbs is a mofo. The Loosening - The Bro sat in the driver's seat and manually braced the wheel. I "womaned" the breaker bar with extension pipe and stood outside the car. Before I pressed down he said "If it gives suddenly, stop immediately. I'd rather not lose a finger." "Right," I said. I pressed gently first and then harder. The breaker bar started to flex just a little, and then the nut relinquished its grip slowly. Fortunately, it did not rapidly give way.

Removing the cluster was fairly cut and dry. We noted all the wire locations. We brought it indoors for disassembly. Good News - the batteries are not corroded. Bad news - they are spot welded to the metal tabs and covered with red glue. I took one look at it and said "There is no way we can safely remove them in the few hours we have available today. I'm going to polish the plastic lens now." The Bro stared at the circuit board for half an hour while I polished the lens which is much better now. We also changed the 2 main light bulbs and 3 indicator bulbs: oil pressure, brake fluid, and brake lining.



If you cannot see the picture let me know. My computer is not loading it.

Replacing the cluster was pretty cut and dry. Replacing the wheel was minor-ly bearish. This time I sat in the passenger seat and braced the wheel. (We did follow the wheel locking/unlocking instructions per the Dash Removal instructions. But the Bro wanted to manually brace the wheel in addition.) The Bro stood outside the car and lifted the wrench handle to torque the nut. After some groaning from both of us, the wrench clicked. Then the Bro insisted on a second torquing. I moaned but agreed. Click. Reconnected battery. Beemie started right up. Everything seemed fine. Until today.

Now the Break Lining light has become turning on and off somewhat randomly - perhaps related to bumps in the road. I think the brake pads are fine. In January, the mechs said that the pads had 70% remaining. I have not done any usually heavy braking lately. Also, the wheel is angled one notch too far in spite of the alignment mark scribing. I can live with this for a while.

So I'm not sure what to do at this point. I'm hoping that the indicator light problem will "go way." I suppose that I inadvertently created this problem in my desire to know if the IC batteries were corroding away the circuit board.

Thoughts anyone?

Thanks, Kelly
I think it is more likely to be a coincidence. Check your brake pads. Check all of them, but the sensor are located in the front left and rear right. If the pads are good, the sensor may have become dislodged, or the wire may have chafed and caused this. The light generally acts like that when the pads are just getting to the sensor. If the pads really are worn, the light will start coming on more and more frequently and for longer periods of time until it just stays on constantly.

BTW, it is actually not good to re-torque the bolts as it will tighten slightly more each time before clicking. It isn't a huge deal generally, but it is most important on things like bearings and head bolts. Also, the trick to replacing the batteries is to actually just unsolder the tabs from the board rather than trying to separate the batteries from the tabs.



Edited 1 time(s). Last edit at 03/09/2009 02:08AM by Andy 90 325i.
The easiest thing to do is just buy a new SI board. They now have some that do not have any batteries so it will never need replacing again. Also, I would guess that your brake lining light was probably burned out and since you replaced it you are now getting the warning. If your brakes are fine then you need to check the sensor connections and put some dielectric grease in there. They tend to get corroded and give false signals. You should also make sure that the wires are not flopping around either as this can cause your connection to fail intermittently every time you go over a bump. The brake lining warning system has given a lot of people so much trouble that they generally just take out the bulb as the solution. The worst that can happen is you ruin your rotors which would probably have needed replacing anyway!
Quote
wodcutr
The easiest thing to do is just buy a new SI board. They now have some that do not have any batteries so it will never need replacing again. Also, I would guess that your brake lining light was probably burned out and since you replaced it you are now getting the warning. If your brakes are fine then you need to check the sensor connections and put some dielectric grease in there. They tend to get corroded and give false signals. You should also make sure that the wires are not flopping around either as this can cause your connection to fail intermittently every time you go over a bump. The brake lining warning system has given a lot of people so much trouble that they generally just take out the bulb as the solution. The worst that can happen is you ruin your rotors which would probably have needed replacing anyway!


Humm - a new board without batteries. Sounds pretty good.

I will investigate the brake situation. I still have the old light bulbs that I removed. I can check for burnouts.

Thanks, Kelly
rkj
Quote
Kelly
Hi All,

So, the Bro arrived Fri evening with a Craftsman MicroTorque wrench. Apparently he had* to visit 3 tool shops on the drive to my place.
( * = easily replaced with "chose" in this case.)

Sat morning Beemie went "under the wrench" to remove and reinstall the Instrument Cluster. The main goal was determining if the batteries could be remotely located; the minor goals were to replace light bulbs as a preventative measure and buff out some etched white spots on the clear front plastic cover. We followed the E30 Dash Removal instructions to remove the steering wheel. And I have to say that 58FtLbs is a mofo. The Loosening - The Bro sat in the driver's seat and manually braced the wheel. I "womaned" the breaker bar with extension pipe and stood outside the car. Before I pressed down he said "If it gives suddenly, stop immediately. I'd rather not lose a finger." "Right," I said. I pressed gently first and then harder. The breaker bar started to flex just a little, and then the nut relinquished its grip slowly. Fortunately, it did not rapidly give way.

Removing the cluster was fairly cut and dry. We noted all the wire locations. We brought it indoors for disassembly. Good News - the batteries are not corroded. Bad news - they are spot welded to the metal tabs and covered with red glue. I took one look at it and said "There is no way we can safely remove them in the few hours we have available today. I'm going to polish the plastic lens now." The Bro stared at the circuit board for half an hour while I polished the lens which is much better now. We also changed the 2 main light bulbs and 3 indicator bulbs: oil pressure, brake fluid, and brake lining.



If you cannot see the picture let me know. My computer is not loading it.

Replacing the cluster was pretty cut and dry. Replacing the wheel was minor-ly bearish. This time I sat in the passenger seat and braced the wheel. (We did follow the wheel locking/unlocking instructions per the Dash Removal instructions. But the Bro wanted to manually brace the wheel in addition.) The Bro stood outside the car and lifted the wrench handle to torque the nut. After some groaning from both of us, the wrench clicked. Then the Bro insisted on a second torquing. I moaned but agreed. Click. Reconnected battery. Beemie started right up. Everything seemed fine. Until today.

Now the Break Lining light has become turning on and off somewhat randomly - perhaps related to bumps in the road. I think the brake pads are fine. In January, the mechs said that the pads had 70% remaining. I have not done any usually heavy braking lately. Also, the wheel is angled one notch too far in spite of the alignment mark scribing. I can live with this for a while.

So I'm not sure what to do at this point. I'm hoping that the indicator light problem will "go way." I suppose that I inadvertently created this problem in my desire to know if the IC batteries were corroding away the circuit board.

Thoughts anyone?

Thanks, Kelly

Hey Kelly

Why all the wheel holding, the locking mechanism will do that, and the big nut, it doesn't have to be super tight but ....

Your brake lite hassle is a normal state of affairs for the Thirty, I remove the bulb from this system and just keep up with pad wear with a visual once in a while.

Si board with no batts?, tell me more thumbs up I'm all set to use an external battery box outside the cluster.

Rick
Quote
rkj

Si board with no batts?, tell me more thumbs up I'm all set to use an external battery box outside the cluster.

Rick

Hi Rick,

Woodctr said there was a new circ board w/o the batteries. Maybe he can chime in with the details.

Knowing there is a battery free version, when mine dies I'll probably use this version.

;-) Kelly
Programa makes a battery less version of our SI boards. Apparently they update the old boards with new circuitry to eliminate the Ni Cads. You have to send in your old board for a core charge refund when you purchase these. I have not used one personally, but I would think that it probably works better than the old version. More in line with all the new stuff BMW has for 2009. Pelican has both versions available, but you can probably get it cheaper on ebay, as I have seen them there too.
Quote
wodcutr
Programa makes a battery less version of our SI boards. Apparently they update the old boards with new circuitry to eliminate the Ni Cads. You have to send in your old board for a core charge refund when you purchase these. I have not used one personally, but I would think that it probably works better than the old version. More in line with all the new stuff BMW has for 2009. Pelican has both versions available, but you can probably get it cheaper on ebay, as I have seen them there too.

The new boards must use flash RAM to contain the SI data instead of the old battery backup method. I imagine they have revamped the boards to properly distribute power to the other cluster gauges as well B)
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 39
Record Number of Users: 3 on September 29, 2015
Record Number of Guests: 109 on June 08, 2017