Welcome! Log In Create A New Profile Recent Messages

Advanced

Antenna actuator drive belt

Posted by Bob in Everett 
April 05, 2017 07:32PM
Suffering from the failed antenna drive so found one from salvage, it too had the same problem. Motor runs but no motion. Disassembled and found broken belts in both. So I went online and eventually found what appears to be a source for replacement. Unfortunately the belts are not expensive but the minimum order value and minimum shipping cost drive the cost way up. So, I ordered several so the cost each was not so bad.
So, if anyone wants one, I could share for a reasonable price. Should have in hand end of next week.

Bob in Everett
April 19, 2017 08:41PM
I could use one of those. How much would it cost to mail one to Ottawa, Canada?
April 20, 2017 11:26PM
Ferdinand,
I would be happy to mail you one for $7 postage included. The list price online is $4 but with the minimum order size charge and shipping I have almost $6 in each.

I have installed one so far but the new belt appears to be about one millimeter shorter than the old belt and I had to elongate the mounting holes for the motor to put it on with out excessive tension. Does work though. just took a little work with a small rat tail file.

Let me know if the price is ok.

I probably should make a video of the process. It is not difficult to figure out though.

Bob in Everett
April 21, 2017 12:01PM
Neato! I'm sending you my address info via PM.
April 22, 2017 12:39AM
Now I have to find the PM.

Bob in Everett
April 22, 2017 12:45AM
Got your message.

Bob in Everett
Drive belt replacement.
The new belt is about 1.5 mm shorter than the old one.
See attached picture.

1. lift the two prongs off the motor mounting casting and rotate the clip out of the away.
2. Remove the two large phillips screws and lift out the motor mount leaving the motor attached to the wires.
3. Remove the two smaller phillips screws holding the motor to the cast mounting.
4. discard the belt adjustment cam.
5. Using a small rat tail file elongate the motor mounting holes so the motor can be about 1.5 mm closer to the large pulley. Do not just make the holes bigger as the screws will then need washers.
When assembled with the new belt, the motor should turn freely by hand with no binding. If not, elongate the holes a small amount more.

Bob in Everett
Attachments:
open | download - AntennaSmall.jpg (315.5 KB)
That belt adjustment cam is pretty clever. The hole for the motor is offset from the centre.


Mounted with the cam turned this way, tightens the belt.


Or with the cam turned this way, it loosens the belt. Seems simple enough.


Except, nothing's ever simple...

The new belt is just that little bit too tight. So I did as Bob suggested, and elongated the mounting holes for the motor allowing it to be positioned slightly closer to the big sprocket.

I only had one small misadventure. While I had the case open, I figured I'd take the whole gizmo apart to give everything a good cleaning. When taking the C-clip off the centre shaft, of course the little thing when zinging over my shoulder to land in the driveway behind me. I saw approximately where it went, but that damn C-clip is the exact same colour as the blacktop in my driveway, so it took me nearly half an hour on my hands and knees crawling around the driveway before I found it again. D'oh!

Otherwise, mission accomplished. The radio antenna goes up and down again. Yippee!
Ferdinand,
Glad you were successful. It is really gratifying to have the old car doing what it is supposed to do.

Bob in Everett
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 32
Record Number of Users: 3 on September 29, 2015
Record Number of Guests: 109 on June 08, 2017