Welcome! Log In Create A New Profile Recent Messages

Advanced

Okay, I'm calling it thumbs up

Posted by rkj 
rkj
September 05, 2013 10:32PM
So, ever since I bought this new car I've been having nagging fears I bought a stinker. I've been doing work on it while I was waiting on the title (had to be noterized by the pervious owner and signed over). I finally got everything together last week late and made the dmv, got plates and was looking forward to a nice long drive.

I took off and headed for some neat back roads out on Montauk Point, after about an hour of having the time of my life (this car is balanced just right) I pulled over to grab a call and has I was sitting there the oil light came on! confused smiley Crap

I gave it a little tap on the gas and the light went right out.... I freaked, my worst nightmare coming true... I turn and headed for home right away, freaked out! As I got closer to home though I decided to really check out the car so I pulled over and decided to check things out. After iding for a minute the light started to flicker, Ha, maybe it's just a sending unit!

This morning I put a new one in and after driving all day everything is fine, Whew :bow: Thank you Bmw gods.



perseverance furthers
September 05, 2013 10:44PM
Had a similar problem myself on a road trip with a Suburban. Was sure gratified to discover the sensor sending unit was bad. The relief is great stuff.

Bob in Everett
September 06, 2013 06:56AM
Was this the 330ci you just bought?
:o

Oil pumps should last as long as the engine...
My old Mercedes Benz has oil pressure gauge, When starting, it rises to the full scale. When hot, it shows a bit above 1 Bar at idle, and 3 Bar (full scale) when accelerating.
The new ones have no oil pressure gauge, is too much information form most people.

As long as there is the right oil at the correct level, you should be fine, it was the pressostat sender that gone bad.

smileys with beer
rkj
September 07, 2013 05:27PM
Yes, this was on the 330. Wow, what a load off that was! I saw my whole investment go up in smoke there for a moment :eyes:
September 10, 2013 01:06PM
As long as the pressure goes up when you touch the throttle, you're fine.



Quote
Jose Pinto
As long as there is the right oil at the correct level, you should be fine

Not really true. As long as you have good oil pressure, you should be fine. The lower the oil level, the higher the thermal load on it, so you should take care and drive carefully. When the oil level is fine and you have low pressure, you should stop asap.


The more gauges on a dash, the better I like it. For instance: without a coolant temp gauge I would never have noticed my thermostat was on its way out.
rkj
September 10, 2013 09:59PM
After a few hundred miles yesterday, I have to report, It's all good. The car is a little on the stiff side (came with M suspension and 17 inch wheels) but that's fine with me. The 3 litre motor with the six speed manual is a dream to work with. Yeahh, just like the old days! Only with a more balanced platform smileys with beer Love this car... smiling smiley
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 7
Record Number of Users: 3 on September 29, 2015
Record Number of Guests: 116 on November 11, 2017