Welcome! Log In Create A New Profile Recent Messages

Advanced

I came back.

Posted by blacke30 
September 06, 2010 09:19PM
Hello fellow forum members. I just found out this was back. My name is Steve, I live in Langley, B.C. not too far from USA border just east of Vancouver.
Peter might remember me we chatted abit a few years ago. Anyways, I will be lurking around the site. Cheers to all.
September 06, 2010 11:54PM
Hey Steve,
It's been quite a while eye popping smiley

Glad you found us again.

Two years ago, the forum was hijacked by some Russian hacker. We couldn't make any contact with Gustavo Melo who owned the original BEN and we had to reconstitute it in this newer more secure form.

There aren't many of us left; as our E30s retire; but you should recognize most of the regulars who still post.

Now that you're back in; swing over to the Community and Technical forums B)
September 07, 2010 12:04PM
Quote
Archeo-peteriX
Two years ago, the forum was hijacked by some Russian hacker. We couldn't make any contact with Gustavo Melo who owned the original BEN and we had to reconstitute it in this newer more secure form.
Yup. I was hoping we could keep the old bmwe30.net domain, but at the time Gustavo wanted to keep it, which was understandable. But since then, he apparently let the domain name registration lapse, and before I knew it, bmwe30.net was snapped up by Japanese cybersquatters. :X We'll never get it back now.

__________
Dave
'91 325iX
September 08, 2010 11:46PM
Wow, thats pretty bizarre. I was wondering what happened.
I am slowly working on an e28 535i. My wife will be driving it. She has an e30 right now and I am killing an 89 jetta commuting to Richmond. See you all around. Steve.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 10
Record Number of Users: 3 on September 29, 2015
Record Number of Guests: 116 on November 11, 2017